Bioffa

Exchange 2016 sent mails go to drafts – 421 4.3.2 Service not active

Proprio ieri, in seguito all’installazioen di alcuni aggiornamenti windows, mi sono ritrovato nella situazione in cui non funzionava più il flow delle email di un exchange 2016. Tutti i servizi erano online ma non funzionavano sia le email in entrata sia quelle in uscita.

Nello specifico tutte le email che provavo ad inviare rimanevano nelle Bozze e da li non si schiodavano. Facendo un po’ di troubleshooting mi sono accorto di un paio di errori che mi hanno portato alla soluzione (grazie sopratutto a Google).

Nei log SMTPReceive ogni connessione in ingresso veniva bloccata con questo errore:

Rejecting the non-probe message and disconnecting as transport service is Inactive.

Mentre se provavo ad inviare una mail all’exchange via telnet l’errore che ricevevo era questo:

421 4.3.2 Service not active

Questo mi ha mandato un po’ in confusione visto che il servizio transport era attivo ed anche riavviandolo la situazione non cambiava.

Dopo un po’ di ricerca su internet ho trovato qualcuno con gli stessi miei errori. Come prima cosa consigliava di vedere lo stato dei componenti exchange con questo comando:

Get-ServerComponentState -Identity ServerName

Ed effettivamente tutti i componenti erano nello stato Inactive quindi il problema era sicuramente quello:

Per rimetterli Active ho dovuto dare questo comando:

Set-ServerComponentState -State Active -Requester Functional -Identity -Component ServerWideOffline

Istantaneamente tutti i componenti sono passati allo stato Active ed exchange ha ripreso a gestire le email creando le code per la consegna e ricevendo tutti i messaggi accodati sull’antispam.

Lascia un commento

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

%d blogger hanno fatto clic su Mi Piace per questo: